Introduction to Spatial Pattern Analysis in a GIS Environment





Exercise 2


Pattern Differences








This exercise demonstrates the K Function spatial statistic while at the same time helping you to extend your ArcMap skills.  The K function is a measure of the spatial clustering associated with incident or event data for a series of distance intervals.  With this exercise you will learn to:





Calculate the K function using the PPA macros developed for this workshop.


Join point attribute tables.


Make charts from tables.


Compare two point patterns.





Task 1:  The K function is most appropriate for incident or event data, so this exercise will utilize the crime incident themes (assaults, auto thefts, burglaries, and robberies) prepared in Exercise 1.  In the first task, we will calculate the K function for each crime point theme.





(1)	Open the workshop.mxd map you created in Exercise 1 by double-clicking the “workshop.mxd” file in your student folder.





(2)	If the Crime data frame is not active (the word crime is not bold in the table of contents), right click on the Crime data frame and choose Activate from the popup menu.





(3)	Make sure the checkbox next to the “Assault” layer in the Table of Contents is checked to display the assault incidents.  Check off the other three crime layers so that only the assaults are visible.





(4)	To run a macro, select the Tools menu, Macros option, and then Macros…  Select the macro named “KFunction.KFunction” and press the Run button.  The Macros dialog may also be accessed by holding down the Alt key and pressing the F8 button on the keyboard. 





(5)	To run the K function you will need to specify a point layer and parameters for the K function analysis:





a)	For the Point Layer entry, select “Assaults”.


b)	Map units are in feet. For this analysis, we will set the Distance to 500 and the number of Increments to 10.  This will perform the analysis for 10 distances from 500 to 5000 feet.


c)	Keep permutations set to 0 and the radio button for "Get extent from Analysis Layer" checked.  The dialog should look like the figure on the next page.
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d)	Press the OK button.


e)	Enter “Assault500” as the output table name.





�





f)	Click OK.


g)	The K-Function is quite computationally intensive.  The progress bar at the bottom of the ArcMap window gives you a rough idea of the computation time remaining.  


h)	The K-Function results table will be added to your map.  If you can’t see the results table in the table of contents, make sure that the Source tab is selected.
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(6)	Next, we will make a graph from our new table.





a)	From the Tools menu, choose Graphs, and then Create…


b)	In the Graph Wizard step 1, choose Line graph, and the plain line subtype. �Then press the Next> button.


c)	Choose the Assault500 table in the combo box, and click on the Observed and Random boxes in the Y Axis field box.  The dialog should look like the one below.





�





d)	Click the Next > button.


e)	Step three allows you to change the title and some other chart options.  For now, the defaults will suffice.  Press the Finish button to create the graph.





The random values in the table and on the graph represent the expected value for randomly distributed data.  Notice that the observed values are significantly higher then the random values, and that they steadily increase as the distance interval increases.  The Assault incidents are significantly clustered.  Evaluating how event data are clustering within a series of distance bands and how these patterns change over time, can often provide important clues about underlying processes.  
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Let’s next look at the other crime incident data, using the same parameters we used in the analysis above:





(7)	Calculate the K function values for the AutoTheft, Robbery, and Burglary themes, using the same procedure as step 5.  Rename the output tables “AutoTheft500,” “Robbery500,” and “Burglary500.” Be careful to use the same parameters so we can combine results into a single table and chart in Task 3.


	


(8)	When you have completed step 8 above, you should have 4 K Function tables in your table of contents.


(9)	Save your map by clicking on the save button. �








Task 2:  In task 1, we calculated K values for the entire point layer, and we did not compute a confidence interval.  In Task 2 we will learn how to create a new layer from a subset of the data.  We will perform K function analysis on this subset and run simulations to generate a confidence interval.





(1)	Make the AutoThefts layer visible and check OFF all the other crime layers.





(2)	Choose the selection tool from your toolbar �.





(3)	Click and drag over a portion of the AutoThefts layer that looks interesting to you.  See the example below. Remember, we will be testing this subset to see if it significantly clustered or dispersed.  You can drag and drop as many times as you like until you have a subset that looks good to you.  Do not choose more than one contiguous area.





�





The selected subset should be highlighted.





(4)	Right click on AutoThefts in the table of contents.  From the popup menu choose Data and then Export Data…





(5)	Make sure that the Export: combo box reads “Selected features.”  Use the same coordinate system as this layer’s source data should be selected.  Press this button �, and navigate to your student folder.  Save the layer as a shapefile called “subset.”





(6)	Click the Yes button to add the shapefile to the map.  Turn off the AutoThefts layer so that only the subset layer is visible.





(7)	Use the measure tool � to find the longest distance between two points in your subset.  The distance is shown in the lower left hand corner of the ArcMap window.  Round this number off to the nearest hundred feet, and divide by 20.  This will be your distance increment for the K function analysis.  This is a rule of thumb that will make our maximum distance about half the longest distance between points.  The results become unreliable at larger distances due to boundary effects.





(8)	Run the K function macro by selecting the Tools menu, Macros option, and then Macros…  Select the macro named “KFunction.KFunction” and press the Run button.





a)	For the Point Layer entry, select “subset”.


b)	Map units are in feet. For this analysis, we will set the Distance to the number you calculated in step 7 and the number of Increments to 10.


c)	Set permutations to 19.


d)	Keep the Get Extent from Analysis Layer button selected.


d)	Press the OK button.


e)	Type the output table name as “Ksubset”.


f)	Click OK.


g)	The K-Function results table will be added to your map.


h)	From the Tools menu, choose Graphs, and then Create…


i)	In the Graph Wizard step 1, choose Line graph, and the plain line subtype. �Then press the Next> button.


j)	Choose the Ksubset table in the combo box, and click on the Observed, Random, Minimum, and Maximum boxes in the Y Axis field box.


k)	Click the Next > button.


l)	In Step three press the Finish button to create the graph.





(9)	There should be four lines on the graph.  The maximum and minimum lines represent the confidence envelope created by calculating K function values for 19 simulated random datasets.  If your observed line falls outside this envelope at any distance you can say that your subset is significantly clustered or dispersed and reject the null hypothesis of randomness at the 5% confidence level.  Values above the envelope indicate clustering and values below the envelope indicate dispersion.


(10)	Save your map by clicking on the save button. �
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Task 3:  The third task in this exercise combines the K value tables created in task 1 into a single line graph chart to facilitate the comparison of assault, auto theft, burglary and robbery crime incidents.  





(1)	We will begin by joining all of the K function results into one table.  Right click on Assault500 in the table of contents.  From the popup menu choose Joins and Relates and then Join…  This will bring up the Join Data dialog.





(2)	Make sure the first combo box is set to “Join attributes from a table.”





(3)	In the second combo box select “distance” as the field that we will use to join data in Assault500 table.





(4)	In the third combo box select the table “Robbery500” as the table to be joined to the Assault500 table.





(5)	In the last combo box select “distance” as the field in Robbery500 to base the join on and Click OK.





(6)	Repeat steps 1 thru 5 twice more, but join the “Burglary500” and “AutoTheft500” tables to the Assault500 table.  Note: Base these joins on the “Assault500.distance” field.





(7)	Right click on Assault500 in the table of contents.  From the popup menu choose Open.  Notice that all 4 K function results tables are joined together.  Scroll to the right and see that the field names now include the table names.





(8)	Create one more line graph that includes all four of the K function graphs.  Start by going to the Tools menu, choose Graphs, and then Create…





(9)	Choose a line graph again and press the Next> button.





(10)	Choose the Assault500 table, and select the “Assault500.random,” “Assault500.observed,” “Robbery500.observed,” “Burglary500.observed,” and “AutoTheft500.observed” fields on the Y-axis.  Hint:  Hold the pointer over the field selection boxes to display the entire field name.





(11)	In the Step 3 of the Graph wizard, select “Assault500.distance” as the X-axis label and click the Finish button.  The graph should look similar to the one on the next page.


�





(12)	Save your map by clicking on the save button. �





Does the graph make sense to you?  Try comparing pairs of crime event layers to see which looks more clustered and then compare their K function graphs.  





There are many options in the graph wizard to make a better looking charts and graphs.  You can try experimenting with the advanced options available from step 3 of the graph wizard or exporting the data to other software.  








Task 4: The last task in this exercise will introduce a method for comparing two point patterns.  In task 3 we compared four spatial patterns and their respective K-Function graphs visually.  We can see that some types of crime are more clustered than others, but we cannot say whether these patterns are significantly different.  In this exercise we will use the K-Function for cases and controls to determine whether two patterns are different.  The subject is liver disease.





(1)	Let's start by adding a new data frame.  From the Insert menu select the Data Frame option.





(2)	Right click on the data frame name (New Data Frame 2) in the Table of Contents and select Properties….  Click on the General tab, and enter “Case Control” in the Name text box.  Click the Apply button to change the name.





(3)	Before closing the Data Frame Properties dialog, we will change the coordiante system too.  Click on the Coordinate System tab.   In the box labeled “Select a coordinate system,” navigate through the folders to Predefined, Projected Coordinate Systems, State Plane, NAD 1983 (Feet), NAD 1983 StatePlane Illinois East FIPS 1201 (Feet).  Click OK to set these data frame properties.  Click Yes if a warning dialog appears.





(4)	We are now ready to add the case-control data to our new data frame.  Click the add data button. �   Navigate to your student folder and select the three files "cases.shp," "controls.shp," and "CCBoundary.shp."  Click the Add button to complete this step.





(5)	These data are a subset of a liver disease study.  The controls represent individuals that are deemed susceptible but have not developed the disease.  Take a minute to view each layer separately.  Does one layer look more clustered than the other?





(6)	To perform the case-control analysis, run the macro by selecting the Tools menu, Macros option, and then Macros…  Select the macro named “KCaseControl.KFunctionCaseControl” and press the Run button.





(7)	In the dialog, select "cases" as the case layer and "controls" as the control layer.  Set the distance to 20 feet, increments as 6, and run 19 permutations for the confidence envelope.  Since we now also have a boundary for the study area, we will use this shapefile as the extent of the analysis.  The dialog should like look the one shown on the next page.  Press the OK button when you are finished.
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(8)	Name the results table "CaseControlK."





(9)	Create a graph of the results.  Display the Observed, Minimum, Maximum, and Expected data on the graph.  Remember to label the x-axis with distance.  If an observed value is positive, the cases are more clustered than the controls.  Conversely, if an observed value is negative, the cases are more dispersed than the controls.    If an observed value falls outside the simulation envelope, you can reject the null hypothesis that the patterns are the same.  What can you conclude from your results?  


(10)	Save your map by clicking on the save button. �





That’s it for Exercise 2.  The next exercise explores data using the Gi* statistic.


