Introduction to Spatial Pattern Analysis in a GIS Environment





Exercise 1


Preparing for Analysis








This exercise is designed to familiarize you with the ArcGIS environment, while leading you through steps for preparing data to use in subsequent exercises.  To perform the Gi* and K Function statistics (in exercises 2 and 3), you will need a point dataset.  One of the objectives in creating this workshop is to allow participants to bring and explore their own data.  It is unlikely, however, that the data you may have brought with you is formatted perfectly for use with the Gi* and K function software utilized in this class.  This exercise, therefore, takes you through a variety of data manipulation steps.  Rather than providing you with “ready-to-use” data, it is hoped that this exercise will provide you with clues about how to reformat your own data for analysis.  With this exercise, you will learn how to:





Add shapefiles to a map


Generate X, Y coordinates from polygon data.


Generate a point data layer (event theme) from X, Y coordinates


Change a map’s projection


Summarize a table


Import Excel data





This is a lot to cover, so let’s get started!





Task 1:  Since census data provides the basis for a variety of analytical efforts, this task presents steps for manipulating this type of data.  It comes from Orange County, California, and is provided as an polygon shapefile of census tracts; each tract is associated with demographic attributes.  Our mission for this task is to convert the census tract polygon shapefile into a point data layer and study area layer for later analyses.





Open ArcMap by clicking on the Start menu, selecting Programs, selecting ArcGIS, and finally selecting ArcMap.  After a few seconds the application should come up, and a welcome dialog should appear.





In the welcome dialog choose the A new empty map option, and click on the OK button.





The analysis routines used in this workshop are programmed as macros in ArcMap.  These macros can be loaded in an ArcMap template.  From the File menu, select the New option.  A new document dialog should appear.





Locate the Open File Button, and click on it.  �





Navigate to you student folder and select the file “PPA.mxt.”  Click the open button to create your new ArcMap document with the Point Pattern Analysis template.





We are now going to name and save the new document.  From the File menu, select the Save As… option.  Navigate to your student folder, and save the document as “workshop.mxd.”





We will now add some data to our empty map.  Locate the Add Data button, and click on it. �





The Add Data dialog will appear.  Click on the Connect To Folder button. �





Navigate to your student folder and click the OK button.  You have now established a connection to your student folder using ArcCatalog.





In the Add Data dialog, double-click on your student folder.  Select the file “octracts.shp” and click the Add button.  If a Warning dialog appears, click the OK button.  A polygon layer representing the census tracts of Orange County, California should be visible on your map.  “octracts” will also appear in the table of contents on the left hand side of the ArcMap window.





We can provide a different name for this layer.  Right click on the shapefile name (octracts) in the Table of Contents and select Properties…. Click on the General tab, and enter “OC Tracts” in the Layer Name text box.  Press the Apply button to change the layer name.





Next we will change the display color of the “OC Tracts” layer.  With the Layer Properties dialog still up, (or reopen the Layer Properties dialog) click on the Symbology tab.  Click on the large button that is the same color as the “OC Tracts” layer.





This should bring up the Symbol Selector dialog.  Choose a new color from the large window on the left, or choose a custom color scheme using the Fill Color and Outline Color palettes.  When you have selected a new color scheme, press the OK button.  Press the OK button in the Layer Properties dialog to close the dialog and apply the new color.





We can also provide a different name for the data frame.  Right click on the data frame name (New Data Frame) in the Table of Contents and select Properties….  Click on the General tab, and enter “Orange County” in the Name text box.  Press the OK button to change the data frame name.





Next we want to explore the attribute data associated with each census tract.  Locate the Identify button, and click it. �





Click on any census tract on the map.  This brings up a display of the attribute fields and values for the selected census tract.  Close the Identify Results window.  





To see the values for all census tracts at once, right click on the layer name, “OC Tracts,” and select Open Attribute Table.  Right click on the “POP1990” field at the top of the attribute table.  The popup menu allows you to sort the table, view descriptive statistics of the data, and some other functions.  Try sorting the data and viewing the statistics of this field.





We are now ready to convert this polygon data into a point data set.  Close the OC Tracts attribute table by clicking on the Close button in the upper right hand corner. �





To convert the census tract polygons into point data, we must generate an X and Y coordinate centroid for each polygon.  A macro included in the Point Pattern Analysis template will be used to accomplish this task.


    


a.	To run a macro, select the Tools menu, Macros option, and then Macros… 


b.	Select the macro named “Centroids.Centroids” and press the Run button.


c.	A dialog will prompt you for a polygon layer.  Select “OC Tracts” and press the OK button.


d.	The status bar in the lower left hand corner will indicate that the centroid coordinates are being generated.


e.	When the process is finished, open the attribute table for the OC Tracts layer.


f.	Scroll the table all the way to the right to view the added coordinates.





The X/Y tract centroid coordinates in the attribute table provide a means for generating the point dataset we will use for analysis.  Click on the Options button � at the bottom of the attribute table, and select the Export… option.





Output the table to a file called “ocpts.dbf” in your student folder by changing the output file name and pressing the OK button.





A dialog will ask you if you want the new table added to your current map.  Click on the Yes button.  Close the OC Tracts attribute table.  Notice that the new table is added to the Source view of the Table of Contents.





From the Tools menu, select the Add XY Data… option.  This launches the Add XT Data  dialog.  Set the Table to “ocpnts”, the X field to “X_coord”, and the Y field to “Y_coord.”  For now, we will leave the spatial reference as “Unknown Coordinate System.”  Click OK.





Notice that a new point layer has been added to the view.  At present, however, this new point theme is a temporary dataset.  We must save it as a permanent shapefile.  Right click on ocpnts Events in the table of contents.  In the popup menu, select Data and Export Data…  The Export Data dialog will appear.





Export all features in the same coordinate system as the layer’s source data.  Save the shapefile as “OCPnts.shp” in your student folder.  Click the OK button to export this layer to a permanent shapefile.  Click YES to add the data to the map.





Delete the temporary centroid theme , “ocpts Events”, by right clicking on the theme name in the table of contents and selecting the Remove option.  Before proceeding further save the map by clicking the save button �.





Next we will symbolize and examine median rents in Orange County.  Right click on “OCPnts”, and select the Properties… option.  Select the Symbology tab in the Layer Properties dialog.  Click on “Quantities” in the box labeled “Show:” at left, and select “Graduated Color”.  Set the Value Field to “MEDIANRENT”.





The default point symbols are too small to see the colors very well.  Right click on one of the symbols in the box below the color ramp.  Select the Properties for All Symbols… option.  Change the size (on the right hand side of the dialog) to 8.00.  Click the OK button.





Click the Classify… button and select “Equal Interval” for method, and the number of classes to 3.  Click OK.





Click on the Label for the first classification, and type in “Low” as the new label.  Change the second label to “Moderate”, and the last to “High”.  Click Apply.  Experiment with different color ramps, and when satisfied, close the Properties dialog.





Some of the values are suspicious.  Use the Identify button to investigate individual data points.  Notice the low median rent for one of the coastal tracts, for example.  These zero values are all tracts with no population.  We can remove these invalid data values from our dataset: 


                       


g.	Close the Identify Results window, if it is open.


h.	Choose Select By Attributes… from the Selection menu.


i.	Choose “OCPnts” as the Layer, and “Create a new selection” as the method. 


j.	Scroll to the “Medianrent” field and Double Click on it.


k.	Click on the “=” operator


l.	Double Click on the “0” Value


m.	Click Apply and then Close to close the Select By Attributes dialog.  Notice the selected points.


n.	Click the editor button to bring up the editing toolbar. �


o.	Bring up the Editor menu by clicking on this.  �


p.	Select the Start Editing option.


q.	Press the Delete button to delete the selected points. �


r.	Choose Stop Editing from the Editor menu.


s.	Indicate YES to the verification prompt, and the outliers are removed from your dataset.





The last step is to project the map.  Decimal degrees would be difficult to work with for analyses in exercises 2 and 3, so we will change the map projection.  Right click on the data frame name (Orange County) in the Table of Contents and select Properties….  Select the Coordinate System tab.  In the box labeled “Select a coordinate system,” navigate through the folders to Predefined, Projected Coordinate Systems, Utm,  and Nad 1983.   Click on NAD 1983 UTM Zone 11N, and click the OK button.  Click Yes if a warning dialog appears.  The map is now projected to a Cartesian coordinate system with meters as units.





Congratulations!  Task 1 is complete.  Save your map. �





Task 2:  Often the data we work with does not come nicely packaged in a GIS data file.  Instead we work with a variety of different data sources.  In this exercise we will convert incident data (representing crime occurrences) from an Excel database into point layers for later analysis.  Crime incidents have been recorded for assault, auto theft, burglary, and robbery.  These datasets are used for demonstration purposes only, so many of the attribute fields we might expect to find with police records (victim/perpetrator address, officer name, police beat, etc.) are not included.





Start Excel and Open the file called CrimeData.xls in your student folder.  This Excel database contains 4 worksheets labeled “Assault”, “AutoTheft”, “Burglary”, and “Robbery”.  Notice that these datasets include location fields, X_Coord and Y_Coord, in state plane feet.  Notice, too, that each dataset includes a LOCID field, created by combining the X_Coord and Y_Coord values.  Every record in the crime dataset represents a crime incident, and some of the locations for crime incidents are repeated (examine records 6, 7, and 8 on the assaults worksheet, for example, and notice that all have identical LOCID values).





To import the data for use with ArcMap, we must first convert each Excel worksheet into a DBase table:





a.	Click on the “Assault” tab.


b.	Select the FILE, then SAVE AS menu options.


c.	Set the “Save in:” folder to your student directory.


d.	Set the “Save as type:” to DBASE IV.


e.	Set the “Filename:” to “Assault.dbf”.


f.	Click SAVE.


g.	Click OK to the verification message about multiple worksheets.


h.	Click YES to the informational message regarding formats.  The assaults worksheet is written to disk as a DBase file.


i.	Repeat steps “a” through “h” for each of the other worksheets, changing the tab and filename appropriately: AutoTheft, Burglary, and Robbery.


j.	Once you have created .dbf files for each crime type, close Excel. (Click NO to the Save prompt).





If you closed ArcMap after task 1, start it again and open the workshop.mxd map.  If you skipped task 1 and do not have a saved map, complete steps 1 through 6 for task 1 to open ArcMap and create a new map with the PPA template.





 To keep our data organized, we are going to insert a new data frame.  From the Insert menu select the Data Frame option.  A new data frame will be added to the map.





Right click on the new data frame name, and select the Properties… option from the popup menu.  Click on the General tab in the Properties dialog, and enter “Crime” in the Name text box.  Press the OK button to change the data frame name.


Click on the Add Data button to add the DBase files to the map. � 





Navigate to your student folder.  With the control key depressed, select the “Assault.dbf,” “AutoTheft.dbf,” “Burglary.dbf,” and “Robbery.dbf” files.  Click the Add button.  The DBase tables are displayed in the Crime data frame.





We will now covert our tables into point data event themes.  This is the same process we used to create our “OCPnts” layer.





From the Tools menu, select the Add XY Data… option.  This launches the Add XT Data  dialog.  Set the Table to “Assault”, the X field to “X_coord”, and the Y field to “Y_coord.”  For now, we will leave the spatial reference as “Unknown Coordinate System.”  Click OK.





Next, we will save the new Assault Events layer as a permanent shapefile.  Right click on Assault Events in the table of contents.  In the popup menu, select Data and Export Data…  The Export Data dialog will appear.





In order to avoid overwriting our tables, save the shapefile as the plural “Assaults.shp” in your student folder.  Leave the default options Export: all features and Use the same coordinate system as this layer’s source data selected.   Click the OK button to export this layer to a permanent shapefile.  Click YES to add the data to the map.





Remove the temporary event layer “Assault Events” and the table “Assault,” by right clicking on the layer names in the table of contents and selecting the Remove option.





Repeat steps 10 through 13 with the other three crime tables.  Remember to use plural names (AutoThefts, Burglaries, and Robberies) for the shapefiles.





When all four of the crime layers are added to the map, take a few seconds to view each layer by itself.  You can turn a layer on and off by checking and unchecking the small box to the left of the layer name in the table of contents.





Notice that there are fewer robberies than the other types of crime.  Let’s move the Robberies layer to the top so that we can see them when the other layers are visible.  Select the Display tab at the bottom of the table of contents.  Move the Robberies layer to the top of the Crime data frame by clicking on the layer name and dragging the mouse up.  The black line shows you where the layer will be placed.





Again, we must project the map to a Cartesian coordinate system for analyses in exercises 2 and 3.  Right click on the data frame name (Crime) in the Table of Contents and select Properties….  Select the Coordinate System tab.  In the box labeled “Select a coordinate system,” navigate through the folders to Predefined, Projected Coordinate Systems, State Plane, NAD 1983 (Feet), NAD 1983 StatePlane California V FIPS 405 (Feet).  Click OK.  Click Yes if a warning dialog appears.  The map is now projected to a Cartesian coordinate system with feet as the units.





Some of the layers may be hard to tell apart.  Change the colors by clicking on the current symbol in the table of contents to bring up the Symbol Selector dialog. �





Save your map by clicking on the save button. �





Good work!  In Exercise 2, we will use the K Function to explore spatial relationships in the point data layers created above.


